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The instructions provided below are for upgrading EnergyCAP Enterprise from Release 6.0 to Release 

6.1SP1.   The version number of EnergyCAP 6.1 is 6.1.60.xx.  (xx will correspond to the current build, 

and will be 60 or higher).  This version includes Service Pack 1 to Release 6.1.  These instructions 

apply to EnergyCAP licensees who (1) host their own databases on their SQL Server and (2) access 

the database via LAN connection.   

 

Additional instructions for upgrading from Release 5.x are included in Appendix B. Users with a 

release earlier than 5.0 should submit a Help ticket online (http://support.energycap.com/) for upgrade 

assistance. 
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Here is an overview of the upgrade process: 

 

 Download the Setup file, database upgrade script(s) and supporting documentation. 

 Back up your existing EnergyCAP database.  

 Use SQL Management Studio Express or a similar SQL software tool to execute the 

appropriate upgrade script (provided) on the EnergyCAP database. 

 Execute the Setup file to install EnergyCAP Release 6.1SP1 on each workstation. 

 Use one workstation to perform Post-Installation Actions:  

o Update ENERGY STAR  

o Update Audits  

o Update Reports  

o Update Custom Spreadsheets  

 

Follow all of the steps indicated below for each process. Some steps may require IT assistance. 

 

Required software: web browser, SQL Server Management Studio Express or equivalent 

  

http://support.energycap.com/
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Database Upgrade Procedure 
 

1. Run EnergyCAP.  Close any open bill entry batches and export any bills awaiting export. 

   

2. Click Help-About to verify your program and database version.  In this example, the version is 

6.0 and the database is version 57.  (format:  release.database.build, 6.0/57/74) 

 

 
 

3. Exit EnergyCAP. 

 

4. Locate and download the required SQL scripts to be run against your database (see Appendix 

A for download instructions). You will be upgrading to the latest database version, which is 

DB60.  If you are currently using rel 6.0 and DB57, you need one upgrade script: 

upgrade57to60.sql.  If you are using rel 5.1 or earlier, see Appendix A for file names of 

additional upgrade scripts. 

 

5. Back up your current database and label it as the last backup of DB57 (or DB52 or 49, 

whichever case applies). All users should exit the EnergyCAP software program. 

 

6. Run the upgrade57to60.sql script on your database using an SQL management tool. 

IMPORTANT:  If you are currently at a release earlier than 6.0 and database earlier than 

DB57, you will run more than one script.  Run the earlier script(s) FIRST, in numerical 

sequence from the lower DB number to DB60. This process will usually take from one to ten 

minutes, depending upon database size. 

   

7. A number of SQL messages during the upgrade process is normal and anticipated.  It is 

advisable to make a copy of any SQL messages received in case diagnostics are necessary.  

 

If the completion message says, “Query executed successfully.”, then the database upgrade was 

successful.  If the message says the query was completed with errors, you should restore your 

backup copy of the database and contact EnergyCAP, Inc. Technical Support for further 

assistance.  Be sure to provide a copy of the error messages. 
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EnergyCAP Enterprise Installation Procedure 
 

Install the new EnergyCAP software application on user workstations using the Setup file provided:  

 

1. Download the EnergyCAP 6.1SP1 Setup file per the instructions in Appendix A. 

 

2. Double-click the Setup file to run the installation. 

 

3. Follow the prompts to move forward in the installation wizard. 

 

a. You can install rel 6.1SP1 over top of the prior release (i.e. in the same program 

folder). 

 

b. Accept setup default options.  The database engine option should remain unchecked. 

 

c. Click Finish… You will receive a prompt to reboot your system when done.  Click OK 

to restart the computer. 

 

2. After your PC has finished rebooting, launch EnergyCAP.  

 

3. Login via your usual procedure. The new EnergyCAP release should load as normal.  

 

4. Click Help/About to verify that you are using the most current release. The version number of 

EnergyCAP 6.1SP1 is 6.1.60.xx, where xx is the latest build (60 or higher). 

 

This concludes the EnergyCAP Installation Procedure. 
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Post-Installation Actions 
 

These Post-Installation Actions perform various database maintenance tasks and must be completed 

ONCE from ONE workstation.  There is no need to perform these tasks from EACH workstation. 

 

(If upgrading from Release 5.x, see Appendix B) 

 

1. ENERGY STAR Building Attributes:  If you are using the EnergyCAP – ENERGY STAR 

interface, you must update the ENERGY STAR building attribute schema as follows: 

 

a. Login to EnergyCAP.  You must have ENERGY STAR submittal permission (if you 

do, the ENERGY STAR shortcut button in upper right of Facility Manager will be 

blue.) 

 

b. Click Setup>Facilities to open the Facility Manager. 

 

c. Click the ENERGY STAR shortcut button from the Facility Manager (upper right). 

The ENERGY STAR Interface window will open. 

 

d. Click the Apply Upgrade button (lower left corner of window). EnergyCAP will 

attempt to download the latest schema. If the upgrade was successful, the „Apply 

Upgrade‟ button will disappear, and a message will inform you that the update has been 

successful.  (If the Apply Upgrade button does not appear, it means that either no 

update applies to you at this time, or you do not have an Internet connection and 

therefore the system cannot verify the need for the update.) 

 

  
 

e. If the building attribute update has affected the required data fields for any buildings 

that you have already configured for ENERGY STAR submittal, you will have to edit 

those buildings‟ properties to comply with the latest data requirements. 
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2. AUDIT UPDATES: Update your audits using this procedure. 

 

a. From EnergyCAP, click Analysis>Audits. The Audit Manager will be displayed. 

 

b. Click Audit>Install. 

 

 
 

The Install Auditors window will open.  Click OK. 

 

 
 

 

3. REPORT UPDATES: Install the latest reports.  We have modified EVERY report, so 

installing the latest reports is important! 

 

It is important to determine the final location(s) for the downloaded report files. This will 

depend on how reports are managed -- centrally or locally. 

 

The latest EnergyCAP report files (Crystal Reports .RPT files) must be downloaded from the 

EnergyCAP website and installed into the user report folder(s).  Some or all users may (1) 

share report files on a common network drive and (2) some or all users may maintain private 

report files on their local hard drive(s).   

 

To determine the location of report files for the current user, navigate to the Report Manager 

(Reporting>Reports) in EnergyCAP and click Tools>Options>This Manager as shown 

below.   
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The Report Options window will open. 

 

 
 

Click the Paths tab to view the individual User report path. 

 

To see the GLOBAL report default location, click Tools>Options>Global. The Options 

window will open. Then click the Reports tab to display the current Reports path. 
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If all users access reports on a shared network drive, you will simply install the reports once for 

all users (see below).  If some or all users access reports via local hard drives, you will have to 

install reports multiple times from multiple workstations. 

 

a. To download and install the reports in EnergyCAP, navigate to the Report Manager 

(Reporting>Reports).  (Note:  If there is no Reports button available after clicking the 

Reporting menu bar, this means you are connected to the database via an Internet 

connection.  You must connect to the database via a network connection in order to 

update reports.) 

 

b. Click Update Reports shortcut button.  The Pick Reports to Install window will open. 

 

c. Select the Update from Web radio button; then click the Get Reports button.  

 

 
 

d. Wait for file download – it may take a few minutes.  When ready, the screen will be 

populated with report names.   

 

e. This step is important - be sure the checkbox settings are correct!  First, and most 

importantly, determine if you need to check the Update all users checkbox (see 

circled item above): 

 

i. If your users access reports on a shared network folder, be sure to check 

the Update All Users checkbox.  This will install the reports for all users at 

once. You do NOT have to run the Update again for each user. 

ii. If you don’t check the Update All Users checkbox (either because you failed 

to do so or because users access reports via local hard drives) you will have 

to run this process over again for each user.  

 

f. Note that the reports are listed in order by Modified date, latest at the top.  The installer 

will automatically Include only new and revised reports. 

 

g. Click OK to begin the report installation process.  New and updated report RPT files 

will be installed into the Reports Path and the reports will be registered in the database 

for designated user(s) and report stored procedures will be updated in the database.  

Important – This process may take a long time if you have many users to update.   
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h. Click Close to close the Log window. 

 

Reminder! If all users are accessing the same common Reports Path on a shared 

network folder, no further action is required (assuming you properly checked the 

Update all users checkbox).  However, if any users access reports from a Reports 

folder on their local hard drive, the reports installation must be repeated on these 

workstations with Update all users unchecked. 

 

i. Reports are updated monthly as bugs are resolved.  A new report ZIP file is posted for 

download/updating in months that report changes were made.  To keep up to date on 

what reports have been modified from month to month, please see the online list at 

http://www.energycap.com/reportupdates 

 

j. One final step: From the Report Manager in EnergyCAP, click the Repair Reporting 

Table menu item.  This option automatically repairs any report table problems (called 

the BillAccountMeter table in SQL) that might result in billing data being omitted from 

PowerViews, meter history lists or reports.  The Repair Reporting Table operation 

can be performed as often as you like; there are no negative consequences. 

 

 
 

4. CUSTOM SPREADSHEET UPDATES: To update custom spreadsheets: 

 

a. Click Analysis>Custom Spreadsheets. The Spreadsheet Manager will be displayed. 

 

b. Click File>Import. The Open window will be displayed. 

 

c. Navigate to the EnergyCAP installation folder (usually C:/Program Files/EnergyCAP 

Enterprise). 

 

d. Click to select the ECAP_CustomSpreadsheets_v6_1_DB60.xml file. 

http://www.energycap.com/reportupdates
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e. Click Open. The Spreadsheet Manager will be updated with new filter and format 

options. 

 

 

 

The upgrade has been completed. There are many new features and updates in EnergyCAP release 

6.1SP1.  We recommend that you read the Release 6.1 and Service Pack 1 Release Notes to 

familiarize yourself with the new functionality.  
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APPENDIX A: File Download Procedure  
 

1. Open your web browser and navigate to www.energycap.com/showdownloads.asp 

 

2. Input the Username and Password indicated below into the fields provided. Then click Login. 

A download folder list will become visible. 

 

 
 

3. Expand the download folder list by clicking the „plus‟ (+) sign.   

 

 
 

4. Click on the ece_setup6-1-60-xx.exe file in the Release 6.1 folder. The File Download 

window will open. (xx will be build 60 or higher) 

 

5. Click the Save button and choose a location on your hard drive for the installation file.  

 

6. Repeat the download process for any PDF files in the same folder (contains additional 

information on the new release). 

 

7. Browse to the Upgrade DB folder. Repeat the download process for the necessary SQL 

script(s) to upgrade your database from its current version to the latest version. You can verify 

your current database version by clicking Help – About from your existing EnergyCAP 

Enterprise software program.  In the About window, you‟ll see the database shown in brackets 

below EnergyCAP Enterprise, like this: [DB 52] or [DB 57]. (NOTE to Database 

Administrators:  You can also verify the current EnergyCAP database version in the Version 

http://www.energycap.com/showdownloads.asp
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field of table SystemData.)  

 

If upgrading from release 6.0, including SP1 or SP2, you will need: 

 upgrade57to60.sql 

 

If upgrading from Rel. 5.1 you may need upgrade49to52.sql (check the HELP/About box in 

EnergyCAP to verify your current database version) and you will definitely need: 

 upgrade52to57.sql 

 upgrade57to60.sql 

 

If upgrading from Rel. 5.0, check the HELP/About box in EnergyCAP to verify your current 

database version. The Database (DB) number is listed under the program name. Depending on the 

DB number, you may need: 

 upgrade47to49.sql OR upgrade48to49.sql 

 upgrade49to52.sql 

 upgrade52to57.sql 

 upgrade57to60.sql 

 

Contact EnergyCAP, Inc. for upgrade assistance if the DB number is lower than 49. 

 

 

8. Verify that you have downloaded the EnergyCAP setup file AND any database upgrade scripts 

you will need.  
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APPENDIX B: Additional Steps for Release 5.x Updates 
 

1. ADO CONNECTION UPDATE.  EnergyCAP, Inc. strongly recommends that all WEB and 

CATALOG SERVICE users update their Catalog Service connection string to ADO (Activex 

Data Objects) for each EnergyCAP database. Use the following example as a guide in creating 

the new ADO string: 

 
Provider=SQLOLEDB.1;Password=e2isnotis;User ID=esuser;Initial 

Catalog=my_energycap_database;Data Source=devdbwin01; 

 

REPLACE the bold items with your information. 

 

USER ID = DATABASE USER ID (used to connect to EnergyCAP db) 

PASSWORD = DATABASE USER ID PASSWORD 

CATALOG = NAME OF ENERGYCAP DATABASE 

DATASOURCE = DATABASE SERVER NAME 

 

Using Internet Explorer, Login to your Catalog Server.  

i. To determine your catalog server location (URL), launch EnergyCAP and click 

on the Globe icon from the Login window.  

 
 

The Options window will open. 

 

ii. Use the highlighted string (it will be DIFFERENT from the example above) as 

the first portion of your catalog server URL. 
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iii. After the highlighted string, ADD admin.asp. In this example the completed 

catalog server string (URL) would be: 

 

http://web.energycap.com/catalogservice/admin.asp 

 

From your Catalog Service Setup browser window, select the EnergyCAP database 

from your current datasources, and replace the existing Connection: information with 

the new ADO string. 

 

 

 

Repeat this procedure for every upgraded EnergyCAP database in your catalog server. 

 

2. ENERGY STAR PERMISSIONS: Upon upgrading from EnergyCAP 5.x, ENERGY STAR 

submittals will be disabled for all users.  The new permission, "execute", will have to be 

granted for all users authorized to submit building data to the EPA for an ENERGY STAR 

rating. Assign User Permissions as follows: 

 

a. Click Setup>Users to open the User Manager.  If Permission will be granted to a user 

ROLE: 

i. Click the User Roles button to open the User Role Editor. 

ii. Click the User Role to be modified. 

 

http://web.energycap.com/catalogservice/admin.asp
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iii. Click the Edit icon. The Role Properties window will open. 

 

iv. Expand the list of Application Objects and scroll down to Facilities. 

v. Expand the Facilities object and select the ENERGY STAR Submittals 

permission (key). 

 

vi. Click the Execute checkbox to enable ENERGY STAR submittals for that user 

role. Then click OK to save your changes and close the Role Properties 

window. 

vii. EnergyCAP will prompt you to apply the changes to existing users. Click Yes to 

apply changes. 

 

b. If Permissions will be granted to a single user and NOT a user role:  

i. Right-click the User Name from the User Manager and select Properties from 

the popup menu. The User Properties window will open. 

ii. Click the Permissions tab. 

iii. Grant the new permission, using the same procedure outlined for User Roles 

(iv-vi, above). 

iv. When done, click OK to save your changes. 

 

3. PowerViews™ STAGING TABLE UPDATES:  

 

Beginning in EnergyCAP Release 6.0, the PowerViews are driven by staging tables which are 

periodically updated instead of being dynamically maintained. The design eliminates delays in 

PowerViews presentment, especially for larger databases.  
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If this has not been done previously (for Rel. 6.0), the database administrator must choose 

one of two options for staging table updates: 
a. An Update PowerViews option, accessible from the Options window 

(Tools>Options-Global, Settings tab) in EnergyCAP, provides for scheduling of 

PowerViews staging table updates upon user login when the PowerViews time 

parameters have been satisfied. 

 
In the example above, the PowerViews staging tables will be updated with current 

database information upon the next user login that occurs at least 12 hours later than the 

last staging table update. 

 

b. A second staging table update option is available and highly recommended if you have 

a large database (over 1,000 utility accounts): An SQL Server management task can be 

created to accomplish the staging table updates at a convenient „down‟ time in company 

operations. The SQL scheduled task must run the following three (3) stored procedures 

against the database, in the sequence indicated: 

 
CB2 

GenerateBillSummaryTables 

GenerateGHGSummaryTables 

 

IMPORTANT NOTE: If this option is chosen, the Update PowerViews checkbox 

(see graphic, above) should be left BLANK to prevent staging table updates at other 

times. 

 

4. GREENHOUSE GAS TRACKING FACTOR UPDATES: For those users who have 

purchased the Greenhouse Gas Tracking module for EnergyCAP and have not yet updated to 

the current set of emission factors (GHG_Emission Factors_005.xml), it is necessary to: 

a. Download the most current Greenhouse Gas (GHG) conversion factors from the 

EnergyCAP website. 

The site address is: http://www.energycap.com/showdownloads.asp 

The Username and Password were provided when the GHG module was purchased. 

The file is GHG_Emission Factors_005.xml 

http://www.energycap.com/showdownloads.asp
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b. After downloading the file to your hard drive, there are several steps that must be 

performed to ensure that the updated factors have been imported and linked to the 

meters in the EnergyCAP database. 

c. From the Facility Manager (Setup>Facilities), click Greenhouse Gases in the Top 

Menu 

 
 

i. Select Import GHG Factors from the submenu.  

a. The Open window will appear.  Browse to the location of the 

downloaded GHG file and click to select it. Then click Open. The new 

factors will be imported. 

ii. Select Set Default GHG Reporting Scope and Factor Type from the 

submenu.  

a. The purpose of the Default GHG Reporting Scope and Factor Type 

settings is to assign these settings to new meters being added to the 

database. 

iii. Select Globally Update Scope and Factor Type for Meters/Counters from 

the submenu.  

a. Verify that the Reporting Scope and Factor Type settings are correct 

for each commodity type. 
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b. Click the Update Scope and the Update Factor Type check boxes 

located adjacent to each of the select Scope and Factor Types.  This tells 

the processor which fields should be updated. 

c. Once the settings are verified and the Update checkboxes are checked, 

click on the Update button in the lower right corner of the window. 

iv. Select GHG Processor from the submenu.  

a. The Assign Factors and Calculate GHG Emission window will open. 

b. Use the settings indicated below (Process All Meters). 

c. Then click the Apply button in the lower center section of the window. 

d. Running the GHG processor ensures that the newly imported updated 

GHG factors are assigned to the meters and then used to calculate the 

GHG Emissions table in the database. 

 

 
 


